Tesseractをherokuで使う方法

「Tesseractをherokuで使う方法」のアイキャッチ画像

herokuで実行したところ下記のエラー発生

調べたところtesseractを4系にあげれば解決するらしく、buildパックを4系で作成しようか悩みましたが、とりあえずaptで入れていく方法にすることにしました
※ どの記事か忘れてしまいましたが、4系に変更すべし、的なstackoverflowの記事がありました。消してしまったので、気になる方は調べてください。

↓3系なので使えない

https://github.com/matteotiziano/heroku-buildpack-tesseract

3系は使えずbuild pack作るのも大変そうなので素直にaptで行きます

下記をterminalで実行

その後、プロジェクトの直下にAptfile を作成し、中身をこのように記載します

修正したファイルをpushしたらterminalで下記を実行

入ってました!!!

最後はpath入れて

実行しましたところ問題なく稼働しました!

参考記事

【Heroku】How to install service and setup environment variable: Use Tesseract OCR as example

Tesseract running error

Installing and using Tesseract 4 on Ubuntu 18.04

Configurin Tesseract OCR in Heroku-16

Heroku Buildpack Tesseract

matteotiziano/heroku-buildpack-tesseract

Using Tesseract on Heroku with Django

How to deploy pytesseract to Heroku

kevin1061517/python-deploy-Tesseract-OCR-to-Heroku