GEM::REQUIREMENT::BADREQUIREMENTERROR DURING HEROKU DEPLOY

「GEM::REQUIREMENT::BADREQUIREMENTERROR DURING HEROKU DEPLOY」のアイキャッチ画像

やったこと

これやっても同じエラー発生。。。。。

で、結論の解決策は

rails6.03系でrails new したbin/ の中身をそのまま6.1系のbin/ フォルダに上書きすればOKでした!!

どうやら問題としてはGemのバージョンとか合わない的なエラーで、調べるとbinとかspringとか諸々関わってそうで、入れ替えたらいけます

誰かの助けになればと思ってますので、参考にしてみてください

参考記事

GEM::REQUIREMENT::BADREQUIREMENTERROR DURING HEROKU DEPLOY

class Gem::Requirement::BadRequirementError